NERSCPowering Scientific Discovery Since 1974

CDT 1.15 was set to default on 4/24/14

April 24, 2014

The Cray Developer Toolkit (CDT) 1.15 was set to default on Edison. The following are the default software versions now: 

atp/1.7.2
cray-ccdb/1.0.2
cray-ga/5.1.0.4
cray-hdf5/1.8.12
cray-hdf5-parallel/1.8.12
cray-lgdb/2.3.0
cray-libsci/12.2.0
cray-mpich/6.3.1
cray-mpich2/6.3.1
cray-netcdf/4.3.1
cray-netcdf-hdf5parallel/4.3.1
cray-parallel-netcdf/1.4.0
cray-petsc/3.4.3.1
cray-petsc-complex/3.4.3.1
cray-shmem/6.3.1
cray-tpsl/1.4.0
cray-trilinos/11.6.1.0
craype/2.1.1
craypkg-gen/1.1.1
papi/5.3.0
perftools/6.1.4
perftools-lite/6.1.4

cce/8.2.6
gcc/4.8.2
intel/14.0.2.144

The CDT 1.15 release note can be found here,
http://docs.cray.com/books/S-9408-1404//S-9408-1404.pdf

Note:

The compiler wrappers from the current default craype/2.1.1 module no longer generate serial binaries that run on login nodes. You will see the following message if attempting to run serial codes on login nodes:

Please verify that both the operating system and the processor support Intel(R) F16C instructions

You configure script may fail as a result. We are working with Cray to resolve this issue. The workarounds are avaible here.