NERSCPowering Scientific Discovery Since 1974

"Unable to open kgni version file /sys/class/gemini/kgni0/version" error

April 13, 2011 by Helen He (0 Comments)

Symptom:

Dynamic executables built with compiler wrappers running directly on the external login nodes are getting the following error message:

% ftn -dynamic -o testf testf.f
% ./testf
./testf: /opt/pgi/10.9.0/linux86-64/10.9/libso/libnuma.so.1: no version information available (required by ./testf)
Unable to open kdreg version file: No such file or directory
Warning: Unable to open kgni version file /sys/class/gemini/kgni0/version errno 2 at line 599 in file cdm.c
LIBDMAPP ERROR: Unable to open kgni version file /sys/class/gemini/kgni0/version errno 2

aborting job:
LIBDMAPP ERROR: Unable to open kgni version file
Aborted

Workaround:

Please use the native compilers such as pgf90, pathcc, etc instead of the Cray compiler wrappers ftn, cc, or CC to build the executable. It will then run successfully on the external login nodes.

% pgf90 -o testf testf.f
% file testf
testf: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), for GNU/Linux 2.6.4, dynamically linked (uses shared libs), not stripped
% ./testf
Test ok
 

Dynamic executables compiled with compiler wrappers could also run successfully on the MOM nodes (via "qsub -I -V -lmppwidth=24 -q interactive").  However, only short jobs (a few minutes) are appropriate to run on MOM node since these are shared resources.

% qsub -I -V -q interactive -lmppwidth=24
... wait for a new session ...

% cd $PBS_O_WORKDIR
% ftn -dynamic -o testf testf.f
% ./testf
Test ok

 


Post your comment

You cannot post comments until you have logged in. Login Here.

Comments

No one has commented on this page yet.

RSS feed for comments on this page | RSS feed for all comments