NERSCPowering Scientific Discovery Since 1974

Resolved -- Error Message: "ModuleCmd_Switch.c(172):ERROR:152: Module 'PrgEnv-­‐cray' is currently not loaded”

June 28, 2012 by Helen He (2 Comments)

Symptom:

User batch jobs with "#PBS -V" in the script are seeing an error message: "ModuleCmd_Switch.c(172):ERROR:152: Module 'PrgEnv-­‐cray' is currently not loaded”.  This is caused by overwriting the default Cray Programming Environment from Cray to PGI.  This message can also be seen with "script" on the login nodes, and "nodestat" on the MOM nodes.  User jobs without "#PBS -V" do not trigger this error message.  Solution: ignore as harmless.

Status:

This issue has been resolved by Cray modifying the PrgEnv module load sequences. 


Post your comment

You cannot post comments until you have logged in. Login Here.

Comments

  • > module list 2>&1 | grep Prg
    32) PrgEnv-gnu/4.1.40

    I ignore the error but It's a bit uncomfortable that the error takes screen the space


    here are my loaded modules:

    > module list
    Currently Loaded Modulefiles:
    1) modules/3.2.6.6
    2) xtpe-network-gemini
    3) darshan/2.2.6
    4) atp/1.6.2
    5) switch/1.0-1.0401.36779.2.72.gem
    6) shared-root/1.0-1.0401.37253.3.50.gem
    7) pdsh/2.26-1.0401.37449.1.1.gem
    8) nodehealth/5.0-1.0401.38460.12.18.gem
    9) lbcd/2.1-1.0401.35360.1.2.gem
    10) hosts/1.0-1.0401.35364.1.115.gem
    11) configuration/1.0-1.0401.35391.1.2.gem
    12) ccm/2.2.0-1.0401.37254.2.142
    13) audit/1.0.0-1.0401.37969.2.32.gem
    14) rca/1.0.0-2.0401.38656.2.2.gem
    15) dvs/1.8.6_0.9.0-1.0401.1401.1.120
    16) csa/3.0.0-1_2.0401.37452.4.50.gem
    17) job/1.5.5-0.1_2.0401.35380.1.10.gem
    18) xpmem/0.1-2.0401.36790.4.3.gem
    19) gni-headers/2.1-1.0401.5675.4.4.gem
    20) dmapp/3.2.1-1.0401.5983.4.5.gem
    21) pmi/4.0.1-1.0000.9753.86.3.gem
    22) ugni/4.0-1.0401.5928.9.5.gem
    23) udreg/2.3.2-1.0401.5929.3.3.gem
    24) gcc/4.8.1
    25) xt-asyncpe/5.23
    26) craype-mc12
    27) cray-shmem/5.6.4
    28) torque/4.2.3.h5_notcpretry
    29) moab/7.2.3-r19-b121-SUSE11
    30) altd/1.0
    31) usg-default-modules/1.0
    32) PrgEnv-gnu/4.1.40
    33) cray-mpich/6.1.0
    34) cmake/2.8.10.1
    35) python_base/2.7.3
    36) numpy/1.6.2
    37) scipy/0.11.0
    38) matplotlib/1.1.0
    39) ipython/0.12.1
    40) python/2.7.3
    41) lua/5.2.2
    42) vim/7.4
    43) nodestat/2.2-1.0401.37252.2.1.gem
    44) sdb/1.0-1.0401.38148.4.27.gem
    45) MySQL/5.0.64-1.0000.5053.22.1
    46) lustre-cray_gem_s/1.8.6_2.6.32.59_0.7.1_1.0401.6845.13.1-1.0401.45009.16.1
    47) hss-llm/7.0.0
    48) Base-opts/1.0.2-1.0401.35378.1.3.gem
    49) cray-libsci/12.1.01

    Posted by Kirill Igumenshchev, 22/10/2013 9:37am (11 months ago)

  • > module list 2>&1 | grep Prg
    32) PrgEnv-gnu/4.1.40

    I ignore the error but It's a bit uncomfortable that the error takes screen space


    here are my loaded modules:

    > module list
    Currently Loaded Modulefiles:
    1) modules/3.2.6.6
    2) xtpe-network-gemini
    3) darshan/2.2.6
    4) atp/1.6.2
    5) switch/1.0-1.0401.36779.2.72.gem
    6) shared-root/1.0-1.0401.37253.3.50.gem
    7) pdsh/2.26-1.0401.37449.1.1.gem
    8) nodehealth/5.0-1.0401.38460.12.18.gem
    9) lbcd/2.1-1.0401.35360.1.2.gem
    10) hosts/1.0-1.0401.35364.1.115.gem
    11) configuration/1.0-1.0401.35391.1.2.gem
    12) ccm/2.2.0-1.0401.37254.2.142
    13) audit/1.0.0-1.0401.37969.2.32.gem
    14) rca/1.0.0-2.0401.38656.2.2.gem
    15) dvs/1.8.6_0.9.0-1.0401.1401.1.120
    16) csa/3.0.0-1_2.0401.37452.4.50.gem
    17) job/1.5.5-0.1_2.0401.35380.1.10.gem
    18) xpmem/0.1-2.0401.36790.4.3.gem
    19) gni-headers/2.1-1.0401.5675.4.4.gem
    20) dmapp/3.2.1-1.0401.5983.4.5.gem
    21) pmi/4.0.1-1.0000.9753.86.3.gem
    22) ugni/4.0-1.0401.5928.9.5.gem
    23) udreg/2.3.2-1.0401.5929.3.3.gem
    24) gcc/4.8.1
    25) xt-asyncpe/5.23
    26) craype-mc12
    27) cray-shmem/5.6.4
    28) torque/4.2.3.h5_notcpretry
    29) moab/7.2.3-r19-b121-SUSE11
    30) altd/1.0
    31) usg-default-modules/1.0
    32) PrgEnv-gnu/4.1.40
    33) cray-mpich/6.1.0
    34) cmake/2.8.10.1
    35) python_base/2.7.3
    36) numpy/1.6.2
    37) scipy/0.11.0
    38) matplotlib/1.1.0
    39) ipython/0.12.1
    40) python/2.7.3
    41) lua/5.2.2
    42) vim/7.4
    43) nodestat/2.2-1.0401.37252.2.1.gem
    44) sdb/1.0-1.0401.38148.4.27.gem
    45) MySQL/5.0.64-1.0000.5053.22.1
    46) lustre-cray_gem_s/1.8.6_2.6.32.59_0.7.1_1.0401.6845.13.1-1.0401.45009.16.1
    47) hss-llm/7.0.0
    48) Base-opts/1.0.2-1.0401.35378.1.3.gem
    49) cray-libsci/12.1.01

    Posted by Kirill Igumenshchev, 22/10/2013 9:37am (11 months ago)

RSS feed for comments on this page | RSS feed for all comments